pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: lang/gcc46 as pkgsrc compiler?

On 06/10/11 10:19 AM, Thomas Klausner wrote:
On Fri, Jun 10, 2011 at 10:17:25AM +0200, Jörn Clausen wrote:
I just had to do a fresh bootstrap of my pkgsrc tree (on Solaris,
using Sun Studio), and decided to switch from lang/gcc34 to a more
recent version. lang/gcc46 compiled and installed fine. But now
every other package fails with

ERROR: This package has set PKG_FAIL_REASON:
ERROR: Unable to satisfy dependency: gcc44>=4.6.0

Is gcc44 the latest version that is allowed per mk/compiler/

Yes. I have made an (untested) patch allowing gcc 4.5 and 4.6.
Let me know how it goes...

Now packages are compiled using gcc 4.6. So far I have only tried a few "harmless" packages, and everything looks fine. I will try to build my usual collection - I am sure there are problems lurking somewhere...

Thanks for the patch,

 Jörn Clausen                    
 Universität Bielefeld

Home | Main Index | Thread Index | Old Index