pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

make update problems


Sorry for the many dumb questions lately...

I have bootstrapped pkgsrc on Solaris using Sun Studio compiler. Then I installed lang/gcc34. To finalize this step, I did "bmake replace" in devel/libtool-base, which was up to now The Right Thing. Well, at least it worked.

When I tried to install the next package, I got:

===> Building binary package for pkg_chk-2.0nb1
=> Creating binary package /software/pkgsrc/source/pkgsrc/packages/SunOS-5.10-i386/All/pkg_chk-2.0nb1.tgz
===> Install binary package of pkg_chk-2.0nb1
pkg_add: /usr/pkgsrc/20110318/var/db/pkg/libtool-base-2.2.6bnb4/+CONTENTS: No such file or directory
*** Error code 1

/usr/pkgsrc/20110318/var/db/pkg/libtool-base-2.2.6bnb4 is an empty directory, but there is /usr/pkgsrc/20110318/var/db/pkg/libtool-base-2.2.6bnb4.xxxxxx which contains the usual files.

I assume "bmake replace" did not work. Is this no valid make target anymore?

I simply moved libtool-base-2.2.6bnb4.xxxxxx to libtool-base-2.2.6bnb4, and everything seems to work now.

 Jörn Clausen                    
 Universität Bielefeld

Home | Main Index | Thread Index | Old Index