pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: devel/boost-libs issue in pkg/42746

On Thu, Mar 31, 2011 at 08:19:04AM +0200, Adam Ciarciński wrote:
> >> I've heard it breaks building with gcc-4.1.x. How about
> >> BJAM_ARGS+=    cxxflags=-fno-strict-aliasing
> > 
> >     cc1plus: error: unrecognized command line option "-std=c++0x"
> > 
> > We should conditionalize the BJAM_ARGS+= line depending on the version of 
> > gcc.
> I've added the condition. I guess that should be enough.

Almost: I just did a cvs update and the new version of breaks
the builds:

boost-libs# bmake package
bmake: "../../devel/boost-jam/../../devel/boost-jam/" line 19: Malformed 
conditional (!empty(PKGSRC_COMPILER:Mgcc) && !empty(CC_VERSION:Mgcc-4.[4-9]*))
bmake: Fatal errors encountered -- cannot continue

bmake: stopped in /usr/pkgsrc/devel/boost-libs

> Thanks for testing this. :)

No problem, I like pkgsrc to be in working order ;-)

Have a nice day,

Francois Tigeot

Home | Main Index | Thread Index | Old Index