pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Error in audio/speex/

> from Thomas Klausner <>:

> On Thu, Feb 24, 2011 at 10:52:31PM +0000, Thomas Mueller wrote:
> > I got an error message from an erroneous configure argument in audio/speex 
> > which I was building as a dependency to emulators/dosbox:
> >
> > configure: error: Unknown FFT fftw3 specified for --with-fft

> This code is only enabled when you add "fftw" to the options for
> speex. (Why did you do that?)

> Anyway, I've fixed this bug (and the mDNS one a few minutes ago).
>  Thomas

Good, though I already fixed the fftw3 bug on my computer, possibly after the
correction appeared in pkgsrc.

I am reluctant to run
cvs update -dP

too frequently because of putting the ABI out of sync, that has happened to me.

Them I have to run
pkg_rolling-replace -uv # not -suv

and that can take a lot of time if I have many packages installed.

I guess I can again 
cvs update -dP

next time I am ready to boot into NetBSD and resume with dosbox.

Hopefully pkg_rolling-replace -uv 
won't take too much time because of the recency of my last cvs update.

fftw built fine, but the problem was the speex Makefile error.

I remember Fourier series and Fourier integrals and transforms from my 
days at Columbia University but don't remember discrete Fourier transforms
unless that is the same as Fourier series.


Home | Main Index | Thread Index | Old Index