pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

PostgreSQL and libtool


I would like to remove libtool as a building tool for PostgreSQL.


1. Libtool is not supported by PostgreSQL. Patching PostgreSQL to use libtool 
is a hack and maintaining the package is a headache.
2. With libtool, there are problems with other packages, like PostGIS.
3. Without libtool, shared libraries are built just fine. We have other 
packages with shared libraries built without libtool (textproc/icu comes to 
4. On Mac OS X, PostgreSQL crashes when built with libtool (see PR/44365). I 
guess other platforms might suffer, too.

I have the update ready, so if there are no reasonable objections, I will 
proceed. :)

Thank you for your understanding.

Kind regards,

Home | Main Index | Thread Index | Old Index