pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkgtools/osabi from pkgsrc-2010Q4 fails to install on aix 5.3

On Tue, 18 Jan 2011 21:04:46 -0600
J Raynor <> wrote:

> pkgsrc reports the OS_VERSION as  The INSTALL script figures out
> the OS_VERSION, but then takes only the first 2 numbers, resulting in 5.3,
> so that's why the values are different.  My suspicion is that the INSTALL
> script shouldn't be taking only the first 2 numbers.  Prior to version 5,
> aix used the first 3 of the 4 digits in the oslevel output to distinguish os
> level.  For example, or
> Should the INSTALL script be changed to look at all 4 numbers in the oslevel
> output?

As long as 4.3.3 and 4.3.1 are supposed to be ABI compatible it would
make sense to only use the first two digits.

Home | Main Index | Thread Index | Old Index