pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

sound in kde4?


how can I get the sound in kde4 and NetBSD 5.1_STABLE?
The systemconfiguration of phonon takes several minutes to launch and I still
can not figure out how to get it to work even after it was started.

I have hal, dbus and famd running.

And there is this .xsessions output:

knotify(1174)/phonon (KDE plugin): 
QDBusError("org.freedesktop.DBus.Error.NoReply", "Did not receive a reply. 
Possible causes include: the remote application did not send a reply, the 
message bus security policy blocked the reply, the reply timeout expired, or 
the network connection was broken.") 

One reason why it doesn't work out of the box is may be because there
are two audio devices in this system and the first one is not a good one:

hdaudio0 at pci1 dev 5 function 1: HD Audio Controller
hdaudio0: interrupting at ioapic0 pin 19
hdafg0 at hdaudio0 vendor 0x1002 product 0x791A nid 0x01 (firmware 
hdafg0: DAC0:02, Digital Digital Other Out: Jack (Unknown, 03)
hdafg0: 2ch/0ch 48000Hz 16/16
audio0 at hdafg0: half duplex, playback

hdaudio1 at pci0 dev 20 function 2: HD Audio Controller
hdaudio1: interrupting at ioapic0 pin 16
hdafg1 at hdaudio1 vendor 0x10EC product 0x0888 nid 0x01 (firmware 
hdafg1: DAC0:02, Analog Speaker: Jack (Green, 14)
hdafg1: DAC0:03, Analog Speaker: Jack (Orange, 16)
hdafg1: DAC0:04, Analog Speaker: Jack (Black, 15)
hdafg1: DAC0:05, Analog Speaker: Jack (Grey, 17)
hdafg1: DAC1:25, Analog HP Out: Jack (Green, 1B)
hdafg1: DAC2:06, Digital SPDIF Out: Jack (Grey, 1E)
hdafg1: ADC3:08, Analog Mic In: Jack (Pink, 18)
hdafg1: ADC3:08, Analog Line In: Jack (Blue, 1A)
hdafg1: ADC4:09, Analog Mic In: Jack (Pink, 19)
hdafg1: 8ch/2ch 44100Hz 48000Hz 96000Hz 192000Hz 16/16 20/32 24/32
audio1 at hdafg1: full duplex, playback, capture, independent


Home | Main Index | Thread Index | Old Index