pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

security/py-paramiko dependencies


While working on the update of fabric to its latest version, I've
reviewed the dependencies of the package.

I'd like to change the dependencies of  security/py-paramiko, replacing
the deprecated security/py-amkCrypto (Python Crypto toolkit no longer
maintained upstream, as mentionned here: in favor of the maintained
security/py-crypto (
The impact of the change is limited to two packages - unless I'm
mistaken - that are currently using security/py-paramiko, namely
sysutils/fabric and wip/py-sshpt. I've tested both are still working
after the change.

Any objections ?
I'll leave py-amkCrypto as it is today, just probably add a CONFLICTS
with py-crypto, as both have some files in common.



Home | Main Index | Thread Index | Old Index