pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

WxGTK28 (or GTK) having problems in 2010Q3 (and current)

Hi everybody,
trying to pkg_chk -u, i've found a problem. This same problem happens if trying 
to compile normally.

When compiling WxGTK, here's the error:
checking for pkg-config... 
checking for GTK+ - version >= 2.0.0... no
*** Could not run GTK+ test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GTK+ is incorrectly installed.
configure: error:
The development files for GTK+ were not found. For GTK+ 2, please
ensure that pkg-config is in the path and that gtk+-2.0.pc is
installed. For GTK+ 1.2 please check that gtk-config is in the path,
and that the version is 1.2.3 or above. Also check that the
libraries returned by 'pkg-config gtk+-2.0 --libs' or 'gtk-config
--libs' are in the LD_LIBRARY_PATH or equivalent.
bash-4.1# pkg-config gtk+-2.0 --libs
-Wl,-R/usr/pkg/lib -pthread -Wl,-R/usr/X11R7/lib -L/usr/pkg/lib 
-L/usr/X11R7/lib -lgtk-x11-2.0 -lgdk-x11-2.0 -latk-1.0 -lgdk_pixbuf-2.0 
-lpangocairo-1.0 -lXext -lXrender -lXinerama -lXi -lXcursor -lXcomposite 
-lXdamage -lpangoft2-1.0 -lgio-2.0 -lXfixes -lcairo -lX11 -lpango-1.0 -lm 
-lfreetype -lfontconfig -lgobject-2.0 -lgmodule-2.0 -lgthread-2.0 -lglib-2.0 

Any hints?

Thank you,

Home | Main Index | Thread Index | Old Index