pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: mouse doesn't work with kdebase-4.4.4nb1

Hi Ray,

perhaps you should do Xorg -configure and then copy file to /etc/X11/ as xorg.conf.

Perhaps lack of the config file is the problem here and perhaps tweaking options in that file may resolve your problem.

Please also see file Xorg.0.log to see if any errors EE are present- maybe you will find some hint.

Does mouse work in plain Xorg env? Try twm and see.


On Sat, Oct 2, 2010 at 8:44 AM, Ray Phillips <> wrote:
Could you tell me how to get a mouse to work with kdebase4-4.4.4nb1 please?

After installing the kdebase4-4.4.4nb1 package on a NetBSD/i386 5.0.2 machine and creating /root/.xinitrc [1] executing startx launches KDE but the mouse cursor won't move.  I've tried on a desktop (tried both a PS/2 and Microsoft optical USB mouse) and Lenevo ThinkPad SL500 laptop (tried both the internal trackpad and a Microsoft optical USB mouse).  The USB mouse lights up when it's plugged in to the ThinkPad and these lines are printed on the console:

uhidev0 at uhub5 port 2 configuration 1 interface 0
uhidev0: Microsoft Microsoft 3-Button Mouse with IntelliEye(TM), rev 1.10/3.00, addr 2, iclass 3/1
ums0 at uhidev0: 3 buttons and Z dir.
wsmouse1 at ums0 mux 0

There seems to be no need to create /etc/X11/XF86Config since /usr/X11R6/bin/xf86config is no longer present.



# cat /root/.xinitrc

Home | Main Index | Thread Index | Old Index