pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Is pango still broken? (vim-gtk2 won't build)

On Thu, 16 Sep 2010 12:43 -0700, "Hisashi T Fujinaka"
<> wrote:
> >> At 9:19 Uhr -0400 16.09.2010, Ian D. Leroux wrote:
> >>>  configure:24333: error: *** Can't link to Pango. Pango is
> >>>  required to build *** GTK+. For more information see
> >>>
> >>
> >> Same happens to rrdtool, see pkg/43885.
> >
> > Wow. I think my problem is that "make update" is broken. It just
> > cleans and quits.
> That was a red herring. It's still broken for me.

There seems to have been some discussion of this on the pkgsrc-changes
list.  In short, the new version of cairo requires a new version of
pixman (0.18.4).  Those of us using base X11 (and the older version
0.12.0 of pixman that ships in xsrc) must therefore rebuild all our
packages against the pkgsrc version of pixman, or revert to an older
branch of pkgsrc until the new pixman gets imported into xsrc.

Is that about right?

Ian Leroux

Home | Main Index | Thread Index | Old Index