pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

graphviz x11=modular problem

Best of my knowledge, this is the first x11
dependency on this box.  Any idea what's wrong?

cd /usr/pkgsrc/graphics/graphviz
cvs -q upd -dP
? work
cat CVS/Tag                                                                     
grep X11 /etc/mk.conf  
make install
The following variables will affect the build process of this package,
graphviz-2.24.0nb4.  Their current value is shown below:

        * XAW_TYPE = standard

Based on these variables, the following variables have been set:

        * TERMCAP_TYPE = termcap

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency libtool-base>=2.2.6bnb3: found libtool-base-2.2.6bnb4
=> Build dependency bison>=1.0: found bison-2.4.2
=> Build dependency perl>=5.10.0: found perl-5.10.1nb2
=> Build dependency pkg-config>=0.19: found pkg-config-0.23nb1
=> Build dependency x11-links>=0.50: NOT found
=> Verifying reinstall for ../../pkgtools/x11-links
ERROR: This package has set PKG_FAIL_REASON:
ERROR: x11-links-0.50 should only be used with X11_TYPE=native.
ERROR: Do not include for X11_TYPE != "native".
*** Error code 1

make: stopped in /usr/pkgsrc/pkgtools/x11-links
*** Error code 1

make: stopped in /usr/pkgsrc/graphics/graphviz

Home | Main Index | Thread Index | Old Index