pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]


Hello Jeremy,

    As you suggested, in mk.conf I changed X11_TYPE=native to
X11_TYPE=modular.  I then removed almost all packages, with the aim of
building everything with a consistent value of X11_TYPE.  Here's what
happens when I try to build www/seamonkey.

Thanks again,
  - Andy Ball

phil# make
=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/pkg/sbin/pkg_admin -K /var/db/pkg fetch-pkg-vulnerabi
=> Checksum SHA1 OK for seamonkey-2.0.4.source.tar.bz2
=> Checksum RMD160 OK for seamonkey-2.0.4.source.tar.bz2
===> Installing dependencies for seamonkey-2.0.4
The supported build options for seamonkey are:

        debug gnome mozilla-jemalloc mozilla-jit

The currently selected options are:


You can select which build options to use by setting PKG_DEFAULT_OPTIONS
or the following variable.  Its current value is shown:

        PKG_OPTIONS.seamonkey (not defined)

The following variables will affect the build process of this package,
seamonkey-2.0.4.  Their current value is shown below:


Based on these variables, the following variables have been set:

        * PYPACKAGE = python26

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency zip>=2.3: found zip-3.0nb2
=> Build dependency autoconf213>=2.13: found autoconf213-2.13nb1
=> Build dependency gmake>=3.81: found gmake-3.81
=> Build dependency perl>=5.0: found perl-5.10.0nb6
=> Build dependency pkg-config>=0.19: found pkg-config-0.23nb1
=> Build dependency x11-links>= NOT found
=> Verifying reinstall for ../../pkgtools/x11-links
ERROR: This package has set PKG_FAIL_REASON:
ERROR: x11-links- should only be used with X11_TYPE=native.
ERROR: Do not include for X11_TYPE != "native".
*** Error code 1

make: stopped in /usr/pkgsrc/pkgtools/x11-links
*** Error code 1

make: stopped in /usr/pkgsrc/www/seamonkey


Home | Main Index | Thread Index | Old Index