pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]


I just tried a pkg_rolling-replace -ruv, with CVS-head, and ran into:

RR> Selecting gnome-keyring (security/gnome-keyring) as next package to replace
RR> Replacing gnome-keyring-2.28.2
===> Cleaning for gnome-keyring-2.30.1nb1
=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Checking for vulnerabilities in gnome-keyring-2.30.1nb1
=> Checksum SHA1 OK for gnome-keyring-2.30.1.tar.bz2
=> Checksum RMD160 OK for gnome-keyring-2.30.1.tar.bz2
===> Installing dependencies for gnome-keyring-2.30.1nb1
The following variables will affect the build process of this package,
gnome-keyring-2.30.1nb1.  Their current value is shown below:

        * PAM_DEFAULT = openpam

Based on these variables, the following variables have been set:

        * PAMBASE (defined, but empty)
        * PAM_TYPE = openpam

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency libtool-base>=2.2.6bnb3: found libtool-base-2.2.6bnb4
=> Build dependency intltool>=0.40.0: found intltool-0.40.6
=> Build dependency gmake>=3.81: found gmake-3.81
=> Build dependency perl>=5.0: found perl-5.10.1nb1
=> Build dependency pkg-config>=0.19: found pkg-config-0.23nb1
=> Build dependency x11-links>=0.50: found x11-links-0.50
=> Full dependency libgnome-keyring>=2.30.1: NOT found
=> Verifying reinstall for ../../security/libgnome-keyring
=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Checking for vulnerabilities in libgnome-keyring-2.30.1
===> Installing for libgnome-keyring-2.30.1
ERROR: libgnome-keyring-2.30.1 conflicts with installed package(s):
ERROR:     gnome-keyring-2.28.2
ERROR: They install the same files into the same place.
ERROR: Please remove conflicts first with pkg_delete(1).
*** Error code 1

make: stopped in /usr/pkgsrc/security/libgnome-keyring

This strikes me as a little odd, as at the top "Replacing gnome-keyring-2.28.2"
and the conflict is with the very same gnome-keyring-2.28.2.

Am I missing something?



Home | Main Index | Thread Index | Old Index