pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg_comp doesn't reflect current pkg-vulnerabilities usage by default.

I'm reluctant to file pr on this, because my track record is that things I 
think are bugs, are miscomprehensions on my part.

But, what I'm *seeing* is that pkg_comp as is, on a virgin NetBSD-current (from 
dailies) cannot correctly intuit the default pkg-vulnerabilities state of the 

It looks to me like out-of-the-box we aren't doing (any more) what we used to 
do, and the vulnerabilities file has either moved, or doesn't exist unless you 
consciously turn it on.

but pkg_comp maketemplate still tries to look for it, and turns AUDIT to YES.. 
which becomes a fail once you try and run a make inside the chroot state


Home | Main Index | Thread Index | Old Index