pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

(FWD) Update gtk2 can;t find pango or cairo 2009Q3

Apologies, forgot to mention a few things:

   NetBSD mail 5.0.1_PATCH NetBSD 5.0.1_PATCH (MAIL) #3: 
   Tue Sep  8 20:42:21 PDT 2009  
   root@mail:/usr/obj/sys/arch/i386/compile/MAIL i386

Trying to upgrade the out of date packages going from 2009Q2 to 2009Q3.
Strange problem with gtk2 not being able to find some packages that 
are installed.  All installed in the default locations.

Where did I go wrong????


Details follow -

checking whether make sets $(MAKE)... (cached) yes
checking pkg-config is at least version 0.9.0... yes
checking for BASE_DEPENDENCIES... configure: error: Package requirements 
(glib-2.0 >= 2.19.7    atk >= 1.13.0    pango >= 1.20    cairo >= 1.6) were 
not met:

No package 'pango' found
No package 'cairo' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables BASE_DEPENDENCIES_CFLAGS
and BASE_DEPENDENCIES_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

*** Error code 1

make: stopped in /usr/pkgsrc/x11/gtk2
*** Error code 1

make: stopped in /usr/pkgsrc/x11/gtk2
*** Error code 1

make: stopped in /usr/pkgsrc/x11/gtk2

[root]: pkg_info|grep pango
pango-1.24.5        Library for layout and rendering of text

[root]: pkg_info|grep cairo
glitz-0.5.6nb2      OpenGL 2D graphics library and a backend for gl output in 
cairo-1.8.8nb1      Vector graphics library with cross-device output support

[root]: pwd;cat CVS/Tag

Home | Main Index | Thread Index | Old Index