pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

wip/gajim fails to compile

Hi pkgsrc-users@

wip/gajim on netbsd-5:

=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Skipping vulnerability checks.
WARNING: No /var/db/pkg/pkg-vulnerabilities file found.
WARNING: To fix run: `/usr/pkg/sbin/pkg_admin -K /var/db/pkg
===> Building for gajim-0.12.1
/usr/pkg/bin/gmake all-recursive
gmake[1]: Entering directory `/usr/tmp/wip/gajim/work/gajim-0.12.1'
Making all in src
gmake[2]: Entering directory `/usr/tmp/wip/gajim/work/gajim-0.12.1/src'
Making all in common
gmake[3]: Entering directory
/bin/sh ../../libtool --tag=CC --mode=compile cc -DHAVE_CONFIG_H -I.
-I../.. -I/usr/pkg/include/python2.5 -I/usr/pkg/include -I/usr/include
-I/usr/pkg/include/freetype2 -I/usr/pkg/include/python2.5
-I/usr/pkg/include/python2.5 -O2 -O2 -pipe -march=pentium4
-I/usr/pkg/include -I/usr/include -I/usr/pkg/include/freetype2
-I/usr/pkg/include/python2.5 -MT idle_la-idle.lo -MD -MP -MF
.deps/idle_la-idle.Tpo -c -o idle_la-idle.lo `test -f 'idle.c' || echo
cc -DHAVE_CONFIG_H -I. -I../.. -I/usr/pkg/include/python2.5
-I/usr/pkg/include -I/usr/include -I/usr/pkg/include/freetype2
-I/usr/pkg/include/python2.5 -I/usr/pkg/include/python2.5 -O2 -O2 -pipe
-march=pentium4 -I/usr/pkg/include -I/usr/include
-I/usr/pkg/include/freetype2 -I/usr/pkg/include/python2.5 -MT
idle_la-idle.lo -MD -MP -MF .deps/idle_la-idle.Tpo -c idle.c -fPIC -DPIC -o
idle.c:28:38: error: X11/extensions/scrnsaver.h: No such file or directory
idle.c: In function 'idle_getIdleSec':
idle.c:44: error: expected '=', ',', ';', 'asm' or '__attribute__' before
'*' token
idle.c:44: error: 'mit_info' undeclared (first use in this function)
idle.c:44: error: (Each undeclared identifier is reported only once
idle.c:44: error: for each function it appears in.)
gmake[3]: *** [idle_la-idle.lo] Error 1
gmake[3]: Leaving directory
gmake[2]: *** [all-recursive] Error 1
gmake[2]: Leaving directory `/usr/tmp/wip/gajim/work/gajim-0.12.1/src'
gmake[1]: *** [all-recursive] Error 1
gmake[1]: Leaving directory `/usr/tmp/wip/gajim/work/gajim-0.12.1'
gmake: *** [all] Error 2
*** Error code 2

make: stopped in /usr/pkgsrc/wip/gajim
*** Error code 1

make: stopped in /usr/pkgsrc/wip/gajim

NetBSD 5.0_STABLE NetBSD 5.0_STABLE (Mangue 0.8) #1:
Tue Aug 25 20:43:44 CEST 2009 i386.

Home | Main Index | Thread Index | Old Index