pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: confused in graphics/libcaca

On Tue, 18 Aug 2009 03:44:59 +0900, Larson, Timothy E. 
<> wrote:

> I'm tinkering with updating this package to the latest version, but am seeing 
> some things that seem odd.  The default option is to use ncurses, but the 
> devel/ncurses doesn't get built on my NetBSD 5 system.  If ncurses was built 
> into it, it would have mouse support.  Instead, in the patches dir I see 
> several that seem to be hacking out mouse stuff.
> Basically my question is, am I misunderstanding how dependencies work in 
> pkgsrc Makefiles, or is something wrong in this packages as it currently is?

NetBSD's builtin curses is almost compatible with ncurses, so usually no need 
to install real ncurses.
For force to use real ncurses, define USE_NCURSES=yes before include 

"Of course I love NetBSD":-)
OBATA Akio /

Home | Main Index | Thread Index | Old Index