pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

sysutils/libpciaccess can be built on netbsd-5.0-alpha


Pkgsrc complains when I try to build systuils/libpciaccess:

avl@axp5:/usr/pkgsrc/sysutils/libpciaccess$ sudo bmake
ERROR: This package is only available for these platforms:
FreeBSD-*-i386 NetBSD-*-i386 OpenBSD-*-i386 FreeBSD-*-x86_64
NetBSD-*-x86_64 OpenBSD-*-x86_64 DragonFly-*-i386 DragonFly-*-x86_64
Linux-*-* SunOS-*-*.
ERROR: This package has set PKG_FAIL_REASON:
ERROR: libpciaccess-0.10.6nb1 is not available for NetBSD-5.0-alpha
*** Error code 1

bmake: stopped in /usr/pkgsrc/sysutils/libpciaccess

But after adding ONLY_FOR_PLATFORM+=    NetBSD-*-alpha to its Makefile
I was able to build and install it.

Alexey Lebedev.

Home | Main Index | Thread Index | Old Index