pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: warning: subversion now at 1.6.2

Jens Rehsack <> writes:

> My point was: they write in INSTALL, that svn requires apr *and* apr-util,
> and don't loose a word about that apr-0.* without apr-util works, too.

You misunderstand: svn *doesn't* work without apr-util; that
document is correct.  pkgsrc's apr0 package includes *both* apr
and apr-util; I don't know why.  I think I may have perpetrated
that.  But, whoever packaged apr 1.x (possibly me, not sure :)
did a better job and packaged them separately.

> Maybe a note should be dropped to the svn developers/packagers to adapt the
> INSTALL file.

If it needed updating, I'd update it myself.

> The sacred cow of downward compatibility ... :)

Eh, it costs very, very little for svn to continue to
support both.

Eric Gillespie <*>

Home | Main Index | Thread Index | Old Index