pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

please help fixing gnutls fallout

Hi -
gnutls-2.8.0, which hit pkgsrc shortly before the freeze,
lacks the "libgnutls-config" script which is used by
some "configure" scripts to locate the library and include files.

The result is that sometimes the build breaks completely, and in
some cases the build succeeds but TLS functionality is silently
removed from the program (which eg means that it can't
speak "https" anymore). In some cases only a build with
some "gnutls" or "tls" pkg option is affected.

This needs to be fixed asap. A patch to "configure" should
help, or the "configure" script can be tricked into
accepting a fake "libgnutls-config" script (as done
for net/wireshark).

It would be great to get some help here, especially from
people who actively use one of these pkgs and can do
a functional test.

best regards

Here is the list of affected pkgs:

Forschungszentrum Juelich GmbH
52425 Juelich
Sitz der Gesellschaft: Juelich
Eingetragen im Handelsregister des Amtsgerichts Dueren Nr. HR B 3498
Vorsitzende des Aufsichtsrats: MinDir'in Baerbel Brumme-Bothe
Geschaeftsfuehrung: Prof. Dr. Achim Bachem (Vorsitzender),
Dr. Ulrich Krafft (stellv. Vorsitzender), Prof. Dr.-Ing. Harald Bolt,
Prof. Dr. Sebastian M. Schmidt

Home | Main Index | Thread Index | Old Index