pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Compiling Etoile, error

Nevermind, got around this with a #define/#undef pair.

2009/5/28 Dan Cirnat <>
I'm trying to compile Etoile trunk (
and cannot fix this error:

In file included from /usr/include/ucontext.h:36,
                 from BlockClosure+debug.m:4:
/usr/include/sys/ucontext.h:44: error: expected specifier-qualifier-list before 'stack_t'

What could cause this and where should I dig for a solution?
The only clue I have from the Etoile silc channel is : "it's a libc thing".

Thank you.

Home | Main Index | Thread Index | Old Index