pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: OpenSSL - what have I actually done!?


I want to update the OpenSSL version that is being used by my Apache 2.2 install on NetBSD 3.1; I'm on 0.9.7d and want to get to 0.9.8j (latest in pkgsrc). In the beginning I thought this was simply a matter of applying the security advisories to OpenSSL but that didn't get me very far. Now I've installed security/openssl from pkgsrc and I'm trying to move on from there.

The problem I have is how to hook it into Apache. I've rebuilt Apache and can confirm that that is installed and running with no problems, but still using the old OpenSSL. I assume that it's statically linked, so it's used the OpenSSL libraries in /usr/lib rather than in /usr/pkg/ lib. The following messages in the output would seem to confirm this:

Package openssl was not found in the pkg-config search path.
Perhaps you should add the directory containing `openssl.pc'
to the PKG_CONFIG_PATH environment variable

However, when I attempt to rectify this by doing:

export PKG_CONFIG_PATH=/usr/pkg/lib/pkgconfig

... before running 'make update', the same message repeats. I don't know that this is necessary anyway as 'pkg-config --modversion libssl' reports '0.9.8j' (the newer version).

Can anybody shed light on this, please? I don't really understand why this is happening when other dependency stuff in pkgsrc works so well.

Thanks & regards,


Home | Main Index | Thread Index | Old Index