pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: libtool --tag issue with pkgsrc under Linux [SOLVED]

On Fri, Nov 14, 2008 at 11:27:04AM +0200, Jonathan Groll wrote:
The following error occurs when building graphics/jpeg under Linux

===> Building for jpeg-6bnb4
./libtool --mode=compile gcc -U_FORTIFY_SOURCE  -I. -c ./jcapimin.c
/usr/pkgsrc/graphics/jpeg/work/.wrapper/bin/libtool[117]: eval: line
1: 14991: Memory fault
*** Error code 11

/usr/pkgsrc/graphics/jpeg/work/.wrapper/bin/libtool line 117 consists
eval "$cmd" || wrapper_result="$?"
where $cmd is
/usr/pkg/bin/libtool --mode=compile gcc -U_FORTIFY_SOURCE -I. -c

If I try bmake a second time, or manually enter the above command the
error I then get reads:
===> Building for jpeg-6bnb4
./libtool --mode=compile gcc -U_FORTIFY_SOURCE  -I. -c ./jcapimin.c
libtool: compile: unable to infer tagged configuration
libtool: compile: specify a tag with `--tag`
*** Error code 1

I can make it proceed one-step if I run:
/usr/pkg/bin/libtool --mode=compile --tag CXX gcc -U_FORTIFY_SOURCE
-I. -c ./jcapimin.c

For the record, in case anyone is googling for this same problem, it
was solved by:
/bin/sh needed to be linked to /bin/dash instead of /bin/ksh

(However, in order to get pkgsrc to bootstrap in the first place under
Linux /bin/sh needed to be changed to link to another shell other than

Cheers, Jonathan

Home | Main Index | Thread Index | Old Index