pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: libgnomecanvas fun

On Thu, Nov 13, 2008 at 12:35:58PM +0100, Thomas Klausner wrote:
> On Wed, Nov 12, 2008 at 04:44:20PM +0000, Patrick Welche wrote:
> > Following lots of dependencies and wondering why gail was missing, I think
> > this patch is useful.
> Which problem exactly are you trying to fix?
> libgnomecanvas doesn't depend on libgail-gnome. (The config.h and
> configure output are the same independent on if the buildlink3 is
> included or not.)

Right - and it turns out that it isn't useful..

> Which version of gtk2 do you have installed?

gtk2+-2.12.11       GIMP Toolkit v2 - libraries for building X11 user interfaces

I was trying to build a new version of my favourite editor, dasher, which
told me:

checking for gnome... gnome-config: not found
configure: error: Package requirements (libgnome-2.0 libgnomeui-2.0 ) were not 

Package gail was not found in the pkg-config search path.
Perhaps you should add the directory containing `gail.pc'
to the PKG_CONFIG_PATH environment variable
Package 'gail', required by 'libgnomecanvas-2.0', not found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables gnome_CFLAGS
and gnome_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

Which is odd because:

# pkg-config --modversion gail


libgnomecanvas- GNOME Canvas library

and in libgnomecanvas-
============================= 2.19.1 ========================
        * libgnomecanvas/ depend on the right gail.pc

and /usr/pkg/lib/pkgconfig/gail.pc exists thanks to
gail-1.22.3         GNOME Accessibility Implementation Library
        -lgailutil.18 => /usr/pkg/lib/

Also in libgnomecanvas-

dnl required versions of other programs
m4_define([gtk_required_version],      [2.0.3])
m4_define([gail_required_version],     [1.9.0])
m4_define([libart_required_version],   [2.3.8])
m4_define([pango_required_version],    [1.0.1])
m4_define([libglade_required_version], [2.0.0])

All but gail appear in buildlinks, but that seems to be irrelevant

# pkg_info gail-1.22.3
Information for gail-1.22.3:

GNOME Accessibility Implementation Library


Required by:

So, still looking...



Home | Main Index | Thread Index | Old Index