[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]
Re: Version requirements for dependancies
On Mon 10 Nov 2008 at 13:38:33 -0500, Chris Ross wrote:
> However, spamprobe doesn't always need the newest bdb. *Any* db4
> might well work for it. I haven't investigated, but I'm sure at least
> 4.5 or better would work. But, since it seems to always require the
> best pkgsrc has to offer, it then uninstalled the db 4.6.xx I had on the
> machine, and by uninstalling that uninstalls many other things that will
> now need to be relinked to the 18.104.22.168 version of db4.
However there is a potential problem if different packages do require
different versions of (say) bdb4. If you're compiling multiple packages,
and the first one installs 4.5 because that's ok for it, you can have
that the next one requires 4.6. Which means really that all packages
that have linked to 4.5 must be relinked (and therefore usually
recompiled) with 4.6.
I must say I am surprised about the way FreeBSD handles this with its
portupgrade tool, since its shared libraries don't even *have* the minor
version in the file name.
___ Olaf 'Rhialto' Seibert -- You author it, and I'll reader it.
\X/ rhialto/at/xs4all.nl -- Cetero censeo "authored" delendum esse.
Main Index |
Thread Index |