pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: bootstrap fails on Solaris 10/x86: conflicting types for 'gai_strerror'

> trying to bootstrap latest pkgsrc (tarball from on
> Solaris 10/x86, I get:

> ...
> gcc  -I. -I.  -g -O2 -DHAVE_CONFIG_H -c getaddrinfo.c
> In file included from getaddrinfo.c:41:
> ./nbcompat/netdb.h:178: error: conflicting types for 'gai_strerror'
> /usr/include/netdb.h:329: error: previous declaration of
> gai_strerror' was here

This was fixed a few days ago.

Best regards, Aleksey Cheusov.

Home | Main Index | Thread Index | Old Index