pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Shouldn't "make replace" pull in pkgtools/pkg_tarup?

On Tue, 28 Oct 2008 17:39:49 +0900, Aleksey Cheusov <> 

>> nawk is
> ...
> nawk, bmake and pdksh are required for bulding packages, not for
> handling binaries. So, your first try to define category3 failed.

Those packages should be bootstrap packages, because without those packages,
even if after bootstrap (or install bootstrap binary kit),
we cannot build those packages.

>> All seems to be pretty consistent:
>> 1. Package management tools.
>> 2. Packages.
>> 3. Optional helper (infrastructure) packages
>> (e.g. for building from the source).
> Optional? - yes. Helper? - yes. Infrustructure? - I think no.
> Infrustructure packages should be in 1).

It probably mean "Optional Infrastructure" packages.

Bootstrap packages should be kept minimam, because
one of them is broken, failed to bootstrap.

"Of course I love NetBSD":-)
OBATA Akio /

Home | Main Index | Thread Index | Old Index