pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: can't bootstrap pkgsrc 2008Q2

>  On Thu, Aug 07, 2008 at 01:13:31PM +0100, Matthias Scheler wrote:
>  >    NetBSD already contains the necessary tools for managing binary
>  >    packages, on other platforms you need to bootstrap pkgsrc to get
>  >    the package management tools installed.
>  It should nevertheless work. Can anyone reproduce this?
>  Joerg

This was a fresh install of 4.0.  Cvs'd to the latest. I built a tailored 
for this machine and installed it.  Rebooted and did "./ ...." to get 
and install a full distribution (wo/X11).  All this seems to have worked as I
expected (maybe there is something broken that affects pkgsrc??).  I downloaded
2008Q2 and untarred it.  I tried building perl5.  It complained about some pkg
tools so I went to build them.  I got some errors about not being able to 
bits.c (actually I think it complained that it could not find bits.c).  Running
find I found bits.c.  

It seemed to me that pkgsrc may have changed since the last system I 
set up (NetBSD3.1 and pkgsrc-200[67] ... been a long time), so I went to the
NetBSD pages and read up on current pkgsrc.  That's when it seemed to be 
saying I
should run bootstrap, so I did.  Those problems were what I reported in the 

I had a similar problem with 4.0 and 3.1 with pkgsrc-2008Q1 (see pkgsrc-users 
Jun 8, 2008) and I did not run bootstrap then.  I have a limited amount of 
I can devote to this problem so I let it sit for a couple of months before 
getting around to trying again with Q2.

I'm sure it's some embarrassingly stupid thing I'm doing  ... or not doing.
I just have no clue what it might be and appreciate any insight offered .  
(Yeah, I know it's supposed to be easy ... it always has been until now :? ).

This weekend I will reinstall 4.0, Q2 and capture the exact errors I was 


Home | Main Index | Thread Index | Old Index