pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

build failure in editors/lyx15 (pkgsrc-2008Q2)

"make" begins and ends thus:

pkg_comp:default.conf# make
=> Bootstrap dependency digest>=20010302: found digest-20080510
=> Checksum SHA1 OK for lyx-1.5.4.tar.bz2
=> Checksum RMD160 OK for lyx-1.5.4.tar.bz2
===> depends-message [lyx-1.5.4] ===> Installing dependencies for lyx-1.5.4
The following variables will affect the build process of this package,
lyx-1.5.4.  Their current value is shown below:


Based on these variables, the following variables have been set:

        * PYPACKAGE = python24

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency libtool-base>=1.5.18nb5: found libtool-base-1.5.24nb6
=> Build dependency gmake>=3.81: found gmake-3.81
=> Build dependency gtar-base>=1.13.25: found gtar-base-1.20
=> Build dependency x11-links>=0.36: found x11-links-0.36
=> Build dependency qt4-tools>=4.1.2nb1: found qt4-tools-4.3.3nb3
=> Build dependency renderproto>=0.9.3nb1: found renderproto-0.9.3nb1
=> Build dependency randrproto>=1.2.0: found randrproto-1.2.1nb1
=> Build dependency fixesproto>=3.0.0: found fixesproto-4.0
=> Build dependency inputproto>=1.4: found inputproto-1.4.3
=> Build dependency checkperms>=1.1: found checkperms-1.10
=> Full dependency texmf-dirs>=1.0: found texmf-dirs-1.4
=> Full dependency perl>=5.0: found perl-5.8.8nb8
=> Full dependency python24>=2.4.2nb4: found python24-2.4.5
=> Full dependency teTeX-bin>=3.0nb7: found teTeX-bin-3.0nb16
=> Full dependency aiksaurus>=1.2.1: found aiksaurus-1.2.1
=> Full dependency aspell>=0.60.4nb1: found aspell-0.60.6
=> Full dependency qt4-libs>=4.1.2nb1: found qt4-libs-4.3.3nb2
===> tools-message [lyx-1.5.4] ===> Overriding tools for lyx-1.5.4
===> extract-message [lyx-1.5.4] ===> Extracting for lyx-1.5.4
===> patch-message [lyx-1.5.4] ===> Patching for lyx-1.5.4
=> Applying pkgsrc patches for lyx-1.5.4
===> wrapper-message [lyx-1.5.4] ===> Creating toolchain wrappers for lyx-1.5.4
  /bin/mkdir -p 
/pkg_comp/obj/pkgsrc/editors/lyx15/default/.buildlink/lib/pkgconfig;  if test 
-f ${src}; then  /bin/ln -sf ${src} ${dst};  fi
===> configure-message [lyx-1.5.4] ===> Configuring for lyx-1.5.4
=> Substituting "python" in lib/ lib/doc/
=> Modifying GNU configure scripts to avoid --recheck
=> Replacing config-guess with pkgsrc versions
=> Replacing config-sub with pkgsrc versions
=> Replacing install-sh with pkgsrc version


config.status: creating src/support/tests/Makefile
config.status: creating src/frontends/Makefile
config.status: creating src/frontends/controllers/Makefile
config.status: creating src/frontends/controllers/tests/Makefile
config.status: creating src/frontends/qt4/Makefile
config.status: creating src/frontends/qt4/ui/Makefile
config.status: creating src/config.h
config.status: executing depfiles commands
config.status: executing default-1 commands
config.status: creating po/POTFILES
config.status: creating po/Makefile

  Host type:                    x86_64--netbsd
  Special build flags:          aiksaurus pch  use-aspell use-ispell
  C   Compiler:                 cc
  C   Compiler LyX flags:
  C   Compiler flags:           -I/usr/pkg/include -I/usr/pkg/include/python2.4 
-I/usr/include -I/usr/pkg/qt4/include -I/usr/pkg/include/freetype2 
-I/usr/X11R6/include  -I/usr/X11R6/include -O2 -I/usr/pkg/include 
-I/usr/pkg/include/python2.4 -I/usr/include -I/usr/pkg/qt4/include 
-I/usr/pkg/include/freetype2 -I/usr/X11R6/include
  C++ Compiler:                 c++ (4.1.2)
  C++ Compiler LyX flags:
  C++ Compiler flags:           -I/usr/pkg/include -I/usr/pkg/include/python2.4 
-I/usr/include -I/usr/pkg/qt4/include -I/usr/pkg/include/freetype2 
-I/usr/X11R6/include  -I/usr/X11R6/include -O2 -I/usr/pkg/include 
-I/usr/pkg/include/python2.4 -I/usr/include -I/usr/pkg/qt4/include 
-I/usr/pkg/include/freetype2 -I/usr/X11R6/include
  Linker flags:
  Linker user flags:            -L/usr/pkg/lib -L/usr/pkg/lib/python2.4/config 
-Wl,-R/usr/pkg/lib/python2.4/config -L/usr/lib -Wl,-R/usr/lib 
-Wl,-R/usr/pkg/lib -L/usr/pkg/qt4/lib -Wl,-R/usr/pkg/qt4/lib -L/usr/X11R6/lib 
  Qt 4 Frontend:
      Qt 4 version:
  Packaging:                    posix
  LyX binary dir:               /usr/pkg/bin
  LyX files dir:                /usr/pkg/share/lyx

**** The following problems have been detected by configure.
**** Please check the messages below before running 'make'.
**** (see the section 'Problems' in the INSTALL file)

** qt 4 library not found !

*** Error code 1

make: stopped in /usr/pkgsrc/editors/lyx15
WARNING: *** Please consider adding fortran to USE_LANGUAGES in the package 
*** Error code 1

make: stopped in /usr/pkgsrc/editors/lyx15

Strangely enough, the various flags do contain references to the QT4

pkg_comp:default.conf# uname -a
NetBSD 4.0 NetBSD 4.0 (Radl-s_Pervasion_of_the_Incorrect_Chord) 
#5: Fri May 16 23:41:31 CEST 2008 amd64

lyx-xforms of course doesn't have this problem, but I notice that it is
doing lots of recompiles if you do "make" then "make package". That's
not so good either.

___ Olaf 'Rhialto' Seibert      -- You author it, and I'll reader it.
\X/ rhialto/at/        -- Cetero censeo "authored" delendum esse.

Home | Main Index | Thread Index | Old Index