pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

m4 for Solaris: What is the fix?


yesterday I bootstrapped pkgsrc HEAD on a Solaris 10 8/07 using
/usr/sfw/bin/gcc in 32 bit mode.
The bootstrap was fine and I went on compiling lyx-xforms. As a
dependency bmake tried to compile m4, but failed with an error related
to a bug in Solaris' math.h. This was discussed back in april:

The thread lists several patches and even a fixed version of m4
Question is: How can this be applied to the m4 package in pkgsrc?
Applying the patches from one of the mails doesn't work for me, patch
(and even gpatch from pkgsrc) think that these are reverse patches,
rejecting the changes.
Using the tarball would mean to create a new package. So for all you
Solaris people out there: What did you do?

Any help would be greatly apreciated.


Home | Main Index | Thread Index | Old Index