pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Problems with mod_python compile on NetBSD 3.0.1

I have some further information.  "make update" in pkgsrc/www/ap2-python 

=> Bootstrap dependency digest>=20010302: found digest-20080510
===> Checking for vulnerabilities in ap22-py25-python-3.2.10
=> Fetching mod_python-3.2.10.tgz
=> Total size: 365768 bytes
Unknown command                                              <<<<<<******** 
Can't open mod_python-3.2.10.tgz: No such file or directory     <<<<<<******** 
fetch: Unable to fetch expected file mod_python-3.2.10.tgz     <<<<<<******** 
=> Checksum SHA1 OK for mod_python-3.2.10.tgz
=> Checksum RMD160 OK for mod_python-3.2.10.tgz
===> Installing dependencies for ap22-py25-python-3.2.10
The following variables will affect the build process of this package,
ap22-py25-python-3.2.10.  Their current value is shown below:

        * PKG_APACHE_DEFAULT = apache22

Based on these variables, the following variables have been set:

        * APACHE_PKG_PREFIX = ap22
        * PKG_APACHE = apache22
        * PYPACKAGE = python25

You may want to abort the process now with CTRL-C and change their value
before continuing.  Be sure to run `/usr/bin/make clean' after
the changes.
=> Build dependency libtool-base>=1.5.18nb5: found libtool-base-1.5.18nb5
=> Build dependency perl>=5.0: found perl-5.8.8nb3
=> Full dependency python25>=2.5.2: found python25-2.5.2nb1
=> Full dependency apache>=2.2.6nb4: found apache-2.2.8
===> Overriding tools for ap22-py25-python-3.2.10
===> Extracting for ap22-py25-python-3.2.10
===> Patching for ap22-py25-python-3.2.10
=> Applying pkgsrc patches for ap22-py25-python-3.2.10
===> Creating toolchain wrappers for ap22-py25-python-3.2.10
/bin/mkdir -p /usr/pkgsrc/www/ap2-python/work/.buildlink/bin && /bin/ln -fs 
apu-1-config /usr/pkgsrc/www/ap2-python/work/.buildlink/bin/apu-c
/bin/mkdir -p /usr/pkgsrc/www/ap2-python/work/.buildlink/bin && /bin/ln -fs 
apr-1-config /usr/pkgsrc/www/ap2-python/work/.buildlink/bin/apr-c
===> Configuring for ap22-py25-python-3.2.10
=> Modifying GNU configure scripts to avoid --recheck
=> Replacing config-guess with pkgsrc versions
=> Replacing config-sub with pkgsrc versions
=> Replacing install-sh with pkgsrc version
configure: WARNING: If you wanted to set the --build type, don't use --host.
    If a cross compiler is detected then cross compile mode will be used.
checking for i386--netbsdelf-gcc... cc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether cc accepts -g... yes
checking for cc option to accept ANSI C... none needed
checking for ar... ar
checking for a BSD-compatible install... /usr/bin/install -c -o root -g wheel
checking whether make sets $(MAKE)... yes
checking for main in -lm... yes
checking for an ANSI C-conforming const... yes
checking your blood pressure... a bit high, but we can proceed
configure: checking whether apxs is available...
checking for --with-apxs... /usr/pkg/sbin/apxs executable, good
checking Apache version... 2.2.8
checking for Apache libexec directory... /usr/pkg/lib/httpd
checking for Apache include directory... -I/usr/pkg/include/httpd
checking for --with-python... /usr/pkg/bin/python2.5
checking Python version... 2.5
checking Python install prefix... /                  
<<<<<<<<<<<<<<*********************************** this is wrong
checking checking where python libraries are installed... /lib/python2.5
grep: /lib/python2.5/config/Makefile: No such file or directory
grep: /lib/python2.5/config/Makefile: No such file or directory
grep: /lib/python2.5/config/Makefile: No such file or directory
grep: /lib/python2.5/config/Makefile: No such file or directory
checking what libraries Python was linked with... 
checking linker flags used to link Python... grep: 
/lib/python2.5/config/Makefile: No such file or directory
grep: /lib/python2.5/config/Makefile: No such file or directory

checking where Python include files are... -I//include/python2.5   
<<<<<******************** WRONG!
checking for --with-python-src... no
checking for --with-mutex-dir... no
Using MUTEX_DIR /tmp

NetBSD 3.0.1 (S) #0: Sun Jul 30 02:26:46 PDT 2006
total memory = 1023 MB

The configure script incorrectly gets the Python install prefix; it's not "/" but 

And, as can be seen
  checking where Python include files are... -I//include/python2.5

should be -I/usr/pkg/include/python2.5

What is broken here?  How do I fix this?

Thanks!  -Mike

Home | Main Index | Thread Index | Old Index