pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

bootstrapping with slackware 12.1 failure

I was wondering if anyone has got Slackware 12.1 to bootstrap pkgsrc
current branch
everytime I issue a: # cd /usr/pkgrc/bootstrap
# ./bootstrap or sh ./bootstrap

it fails with /usr/pkgsrc/pkgtools/pkg_install with the following error.
bmake: don't know how to make /usr/share/groff/tmac/mandoc.tmac. Stop

bmake: stopped in /usr/pkgsrc/work/wrk/pkgtools/pkg_install/work/libfetch
***Error code 2

bmake: stopped in /usr/pkgsrc/pkgtools/pkg_install
Warning:*** Please consider adding c++ to USE_LANGUAGES in package Makefile.

Warning:*** Please consider adding fortran to USE_LANGUAGES in package Makefile.
***Error code 1

bmake: stopped in /usr/pkgsrc/pkgtools/pkg_install
=> exited with status 1

So the trouble seems to be with groff which is installed and
groff_tmac.  I'ved add USE_LANGUAGES to the pkg_install Makefile and
work/*/mk.conf file and error still persists why would it be causing

you must know the ledge of wise and dome to understand your culture of freedom!

Powerfull Allah

Home | Main Index | Thread Index | Old Index