pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: Build failure for ruby18-base-18.6.11 on OS X

On Sat, May 3, 2008 at 1:16 PM, Joe Van Dyk <> 
> On Sat, May 3, 2008 at 11:02 AM, Gerardo Santana Gómez Garrido
>  <> wrote:
>  > May I ask why would you want a pkgsrc build of Ruby when Ruby is a
>  >  first class citizen in Mac OS X?
>  >
>  >  mac:~ santana$ ruby -v
>  >  ruby 1.8.6 (2007-09-24 patchlevel 111) [universal-darwin9.0]
>  >  mac:~ santana$
>  Because I want to be able to manage all software via pkgsrc.  I need
>  to work on OS X, solaris, and linux machines.  It would be nice for me
>  to have a consistent package manager across all of them.
>  Joe

Indeed. I do exactly the same, for Solaris and Mac OS X. Ruby is in my
exception list though.

Apple is serious about Ruby support, so, why bother building Ruby with
pkgsrc, or that's why I thought, and that's my recommendation.

About the error you're getting, running gdb on the core dump will be
helpful to see where miniruby is crashing

Gerardo Santana

Home | Main Index | Thread Index | Old Index