pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg-config dumping core

When building audio/bmpx I noticed pkg-config was dumping core. This is on 
SPARC Solaris:

checking for 
CDIO... /opt/pkg.obj/audio/bmpx/work.ultra10/.tools/bin/pkg-config[5]: 29195 
Segmentation Fault(coredump)
configure: error: Package requirements (libcdio_cdda >= 0.70) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

If I run it manually from the command line, it simply returns 0

# pkg-config --exists --print-errors "libcdio_cdda >= 0.70"

However if I run the pkgsrc wrapper for this package, it dumps core

# /opt/pkg.obj/audio/bmpx/work.ultra10/.tools/bin/pkg-config --exists 
--print-errors "libcdio_cdda 
>= 0.70"
/opt/pkg.obj/audio/bmpx/work.ultra10/.tools/bin/pkg-config[5]: 2938 
Segmentation Fault

The following line in the above wrapper script, causes pkg-config to dump 

 /opt/pkg/bin/pkg-config --exists --print-errors "libcdio_cdda 
>= 0.70"
Segmentation Fault

So I added the following line to audio/bmpx/Makefile, in order to buildlink 
libcdio *.pc files etc:

.include "../../misc/libcdio/"

# cd audio/bmpx
# bmake clean
# bmake configure

This time round pkg-config detected libcdio and returned 0

It shouldn't segfault when it doesn't find a package. This is a bug in 

Home | Main Index | Thread Index | Old Index