pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

[HEADS UP] major OpenLDAP upgrade


after succesfully running OpenLDAP 2.4.x for two months now, I have committed
this update (somewhat forced by the update of databases/db4 to 4.6.x which
OpenLDAP 2.3.x did not support).  See below for major changes and a note for
users of slurpd synchronisation.

The usual upgrade procedure applies: before upgrading, generate an LDIF file
from your database using slapcat(8), which you can import after upgrading
using slapadd(8) or ldapadd(1).  More details can be found in the OpenLDAP
Admin Guide:


On Mon, Dec 03, 2007 at 06:38:35AM -0800, Geert Hendrickx wrote:
> Hi,
> the policy for OpenLDAP has usually been to stick to the latest "stable"
> release (currently 2.3.39), which is why I haven't committed the 2.4.6 update
> yet, but I've upgraded the openldap-* packages locally and have been running
> with 2.4.6 for a while now.  It might be good though if more people could test
> the 2.4.x package before it's declared stable and I commit it.  The diffs are
> attached.
> OpenLDAP 2.4.x brings a lot of new features, including multi-master support,
> dynamic configuration and schema changes, automatic reverse group membership,
> significant performance improvements, etc.  One of the most noticeable changes
> for administrators though is the removal if the slurpd daemon (in favour of
> the sync replication mechanism).  Users of slurpd replication should migrate
> to sync replication before upgrading to OpenLDAP 2.4.x.
> I'd be especially interested in experiences with dynamic configurations, as
> this may require changes to the pkgsrc package to work out-of-the-box  (I'm
> still using slapd.conf myself at the moment).
>       Geert

Home | Main Index | Thread Index | Old Index