pkgsrc-Users archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

policy regarding builtin Perl modules


is there an implicit (or even documented) policy about requiring
Perl modules which come with the Perl 5.8 package?

I know we can do this with constructs like
"{p5-MIME-Base64>=2.11,perl>=5.8.0}" but I seem to remember those are on
the way to being deprecated.

Should I simply omit DEPENDS lines for such modules because I know we have
perl>=5.8.0? Or is it better to keep the lines as inline documentation
with an appropriate comment? Personally, I would tend to do the latter.


Home | Main Index | Thread Index | Old Index