pkgsrc-Changes archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: CVS commit: pkgsrc/pkgtools/pkg_install

On 10/9/2012 11:09, Jonathan Perkin wrote:

What needs to be added to the commit message?
That it's (apparently) not warning on all versions of gcc 4.7?
The error is legitimate, so why isn't SmartOS's gcc picking it up?
Are you using 4.7.2 ?

We use lang/gcc47, so 4.7.0 - are these newer warnings then?

Ah -
I can't say if the warnings appeared between 4.7.0 and 4.7.2; I don't know. These packages are being compiled with the new base compiler in DragonFly 3.2 which is version 4.7.2. It's very near "stock" but it wasn't built with the makefile provided by gcc.


Home | Main Index | Thread Index | Old Index