pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/48532: x11/xrandr wants libXrandr >= 1.4

The following reply was made to PR pkg/48532; it has been noted by GNATS.

From: Robert Elz <kre%munnari.OZ.AU@localhost>
Subject: Re: pkg/48532: x11/xrandr wants libXrandr >= 1.4
Date: Mon, 20 Jan 2014 13:42:18 +0700

     Date:        Sun, 19 Jan 2014 14:15:00 +0000 (UTC)
     Message-ID:  <>
   | >How-To-Repeat:
   |    with X11_TYPE=native (or empty)
   |    cd /usr/pkgsrc/x11/randr
   |    make package
 As I understand it, this combination isn't supposed to work.  There
 are a whole host of packages that exist solely to implement X11_TYPE=modular
 of which xrandr is one (in general, if a program or library of the same
 name exists under /usr/X11R7 then the pksrc version should only be used
 with X11_TYPE=modular).
 There really needs to be some way that these packages could all be marked
 so that people would stop attempting to build them using X11_TYPE=native
 which really makes no sense at all (libraries, include files, ... are all
 incorrect for this stuff there).

Home | Main Index | Thread Index | Old Index