pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/48128: icewm build broken on 6.99.23

The following reply was made to PR pkg/48128; it has been noted by GNATS.

From: Alan Barrett <>
Subject: Re: pkg/48128: icewm build broken on 6.99.23
Date: Sat, 17 Aug 2013 19:53:32 +0200

 On Fri, 16 Aug 2013, wrote:
 >===> Building for icewm-1.2.35nb1
 >gmake[1]: Entering directory `/usr/pkgsrc/wm/icewm/work.earm/icewm-1.2.35/src'
 >  CXX      ymsgbox.o
 >In file included from ylib.h:9:0,
 >                 from
 >error: 'deprecated' was not declared in this scope
 >warning: '__attribute__' attribute directive ignored
 >gmake[1]: *** [ymsgbox.o] Error 1
 >gmake[1]: Leaving directory `/usr/pkgsrc/wm/icewm/work.earm/icewm-1.2.35/src'
 >gmake: *** [base] Error 2
 >*** Error code 2
 I don't know what the correct fix is, but changing line 111 of
 /usr/X11R7/include/X11/Xfuncproto.h from
 # define _X_DEPRECATED  __attribute__((deprecated))
 # define _X_DEPRECATED  __attribute__((__deprecated__))
 allows me to build icewm successfully.
 --apb (Alan Barrett)

Home | Main Index | Thread Index | Old Index