pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/48033 (net/wireshark uses wrong python version)

The following reply was made to PR pkg/48033; it has been noted by GNATS.

From: =?ISO-8859-1?Q?J=F6rn_Clausen?= <>
To: Thomas Klausner <>
Cc: NetBSD bugtracking <>
Subject: Re: pkg/48033 (net/wireshark uses wrong python version)
Date: Thu, 11 Jul 2013 17:00:47 +0200

 On 09.07.13 13:12, Thomas Klausner wrote:
 > I guess the "which elinks&&  elinks" doesn't work correctly. Can you
 > come up with something that does?
 I can install www/elinks and pretend this never happened...
 I have no clever idea how to substitute Solaris "which" with something 
 that behaves like other OSes, nor how to rewrite the Makefile to achieve 
 the same selection in a more portable way.
 An enduring solution would be to create a package "bwhich" and install 
 it during bootstrap, like bmake, nbsed, etc. There were other packages 
 that had to be patched due to the unusual behaviour of "which". But I 
 admit that legacy Solarises are such a corner case that it is probably 
 not worth the effort.
   Jörn Clausen                    
   Universität Bielefeld

Home | Main Index | Thread Index | Old Index