pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/47828: sysutils/libpciaccess 0.13.1 incompatible with xorg-server 1.12.4?

The following reply was made to PR pkg/47828; it has been noted by GNATS.

From: Thomas Klausner <>
To: David Shao <>
Cc: NetBSD bugtracking <>
Subject: Re: pkg/47828: sysutils/libpciaccess 0.13.1 incompatible with
 xorg-server 1.12.4?
Date: Wed, 12 Jun 2013 22:02:54 +0200

 On Wed, Jun 12, 2013 at 06:50:00PM +0000, David Shao wrote:
 >  I recompiled as much as I could on an x86_64 machine without the
 >  __x86_64__ checks and the system still is able to function using
 >  x11/x86-video-vesa as its driver.  Therefore apparently the patch for
 >  FreeBSD to libpciaccess apparently already committed should also work
 >  for DragonFly without change.
 >  The dragonflybsd server for its master src started updating again, so
 >  I was able to recompile world through
 >  "git: Remove MACHINE_ARCH=amd64 and legacy make instructions from makefiles"
 >  I had been worried that there wouldn't be a __amd64__ defined, but
 >  apparently it is.
 >  I removed the checks for definition of __x86_64__ in
 >  sysutils/libpciaccess/patches/patch-src_freebsd__pci.c, replaced
 >  libpciaccess, libdrm, MesaLib, modular-xorg-server, and and
 >  x86-video-vesa, and was still able to fire up xorg in xfce4.
 >  Thanks for checking!
 So I'll leave the patch alone for now but we don't need to feed the
 additional changes upstream. Good to know.
 Thanks for testing!

Home | Main Index | Thread Index | Old Index