pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/47882 ("gtk2+" package doesn't build under NetBSD 6.1)

The following reply was made to PR pkg/47882; it has been noted by GNATS.

From: Matthias Scheler <>
Subject: Re: pkg/47882 ("gtk2+" package doesn't build under NetBSD 6.1)
Date: Mon, 3 Jun 2013 17:09:11 +0100

 On Mon, Jun 03, 2013 at 10:05:49AM +0000, Thomas Klausner wrote:
 > Synopsis: "gtk2+" package doesn't build under NetBSD 6.1
 > State-Changed-From-To: open->closed
 > State-Changed-By:
 > State-Changed-When: Mon, 03 Jun 2013 10:05:49 +0000
 > State-Changed-Why:
 > Done as suggested.
 The change was not sufficient. Only the ABI version was bumped which
 only controls which version of the package is required. I've also
 bumped the API version which controls the builtin versions that
 will be accepted.
 The following three commits ...
 ... ensure the correct behaviour under Mac OS X:
 tron@excalibur:~>otool -L /usr/pkg/bin/xchat | grep freetype 
        /usr/pkg/lib/libfreetype.6.dylib (compatibility version 17.0.0, current 
version 17.0.0)
 tron@excalibur:~>otool -L /usr/pkg/bin/xchat | grep fontconfig
        /usr/pkg/lib/libfontconfig.1.dylib (compatibility version 9.0.0, 
current version 9.0.0)
 My NetBSD build hasn't progressed far enough to tell whether the
 fix works there as well.
        Kind regards
 Matthias Scheler                        

Home | Main Index | Thread Index | Old Index