pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/47441

The following reply was made to PR pkg/47441; it has been noted by GNATS.

Subject: Re: pkg/47441
Date: Thu, 11 Apr 2013 20:42:23 -0400

 On Thu, Mar 28, 2013 at 08:10:05AM +0000, Thomas Klausner wrote:
 >  I don't think that the two libnotify packages can currently be
 >  installed in parallel; I think you can't even have them in the same
 >  pbulk build without problems. Perhaps fixing that would be a good
 >  first step?
 Well, how about we set them to CONFLICT with each other? We have tons of
 packages already which do this. Some even conflict with themselves (in the
 case of some python packages). wip/libnotify could be imported as
 libnotify-dev, so that it's even built after libnotify in the bulk builds and
 thus wouldn't interfere with building the packages that are depending on 
 The deal is that I don't want to sit on this for a while. The updates to the
 compiz packages depend on having this later version of libnotify installed. I
 don't want us to sacrifice versions of packages that are supported by upstream
 for any perceived stability we get by continuing to maintain older versions
 which upstream no longer supports, if that makes sense.

Home | Main Index | Thread Index | Old Index