pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/47259 : Perhaps clang shouldn't be required

The following reply was made to PR pkg/47259; it has been noted by GNATS.

From: John Marino <>
Subject: Re: pkg/47259 : Perhaps clang shouldn't be required
Date: Tue, 08 Jan 2013 10:48:25 +0100

 I know for a fact that gcc 4.7 objc can build gnustep v1.24.0 without 
 any issue.
 gnustep base requires clang, which as this PR show, can't even build 
 gnustep-base on i386.
 Can we consider reworking this package to suck in Clang only if it's 
 required?  Unfortunately, a couple of gnustep mk files are hardcoded 
 with clang.
 At the very, very least, this i386 " undefined reference to 
 `__i686.get_pc_thunk.bx'" problem has to be fixed.  It's been broken for 
 a few months now.  Is anybody working on this regression?

Home | Main Index | Thread Index | Old Index