pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/45284: native Kerberos on Solaris (again)

The following reply was made to PR pkg/45284; it has been noted by GNATS.

From: =?ISO-8859-1?Q?J=F6rn_Clausen?= <>
Cc: Thomas Klausner <>,,,
Subject: Re: pkg/45284: native Kerberos on Solaris (again)
Date: Fri, 26 Aug 2011 10:33:35 +0200

 Again: My question is: Why is this defined at all in this package?
 security/mit-krb5 is v1.8 in pkgsrc. The Kerberos implementation in 
 Solaris 10 is v1.4 (at least that's the version string, internally it 
 has been patched probably to something in between). The actual version 
 of the implementation used, as requested via e.g. PREFER_NATIVE, is 
 determined dynamically in Why isn't it sufficient if a 
 depending package defines the minimal version required with
 DEPENDS+= mit-krb5>=1.8
 and that's it? (BTW: I think that is what mit-krb5-appl tries to do by 
 using CONFLICTS for this.)
   Jörn Clausen                    
   Universität Bielefeld

Home | Main Index | Thread Index | Old Index