pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/44698: Alternative PKGFILE [patch]

The following reply was made to PR pkg/44698; it has been noted by GNATS.

From: Aleksey Cheusov <>
Subject: Re: pkg/44698: Alternative PKGFILE [patch]
Date: Wed, 09 Mar 2011 14:01:11 +0200

 >  That is, if you build a bunch of variant packages with options and
 >  upload them to a package repository it should be possible for people
 >  using pkg_install to download and install them without specifically
 >  having to know the special names;
 A couple of years ago, pkg_summary(5) was introduced for pkgsrc which is
 provided by all bulk build tools and uploaded to the repository together
 with binary packages. Both PKGNAME and PKG_OPTIONS are specified in
 pkg_summary(5). So whatever naming convention you use -- who cares?  It
 doesn't matter at all. With a help of PKGNAME, PKG_OPTIONS and FILE_NAME
 (also present in package summary) you can easily find the filename for
 your favourite binary with a set of options you need.
 BTW, FILEBASE variable I propose to add doesn't prevent anybody from
 creating One True Naming Conventions for binary packages in the future.
 It can easily be implemented *on top* of FILEBASE.
 >  This all hinges on getting the naming right so I think we need to
 >  first figure out what the naming scheme should be, which isn't
 >  entirely trivial to sort out, then arrange to have the package
 >  filename be set automatically rather than by user configuration.
 Naming convention for binaries was discussed at least two times and we
 had no success. The same for bulk builds producing binaries built with
 different options. With a bunch of tools for pkgsrc I have got, notably
 pkgnih, distbb and pkg_summary-utils, I believe I'm closer to the goal
 than anybody else. So, yes, I'm *slowly* moving to this direction and
 need some minor support from pkgsrc side. I believe two lines of code
 cannot break anything in pkgsrc and provide some flexibility to users
 until developer have no final decision about binaries naming convention.
 More over, as I said above new variable FILEBASE can and probably will
 be used for implementing One True Naming Convention. So, it is a small
 step forward. Also, this trivial 3-lines patch allows to do research in
 this area.
 Best regards, Aleksey Cheusov.

Home | Main Index | Thread Index | Old Index