pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

pkg/44693: fonts/ec-fonts-mftraced is no longer need by print/lilypond

>Number:         44693
>Category:       pkg
>Synopsis:       fonts/ec-fonts-mftraced is no longer need by print/lilypond
>Confidential:   no
>Severity:       serious
>Priority:       medium
>Responsible:    pkg-manager
>State:          open
>Class:          sw-bug
>Submitter-Id:   net
>Arrival-Date:   Mon Mar 07 12:50:00 +0000 2011
>Originator:     Ryo ONODERA
>Release:        NetBSD 5.99.47
System: NetBSD 5.99.47 NetBSD 5.99.47 (LEAFGIRL3) 
#5: Mon Mar 7 19:32:31 JST 2011
Architecture: i386
Machine: i386
Without fonts/ec-fonts-mftraced, print/lilypond works fine for me.
For example, files under work/lilypond-2.12.3/input/regression/ can be
compiled properly without fonts/ec-fonts-mftraced.
Now print/lilypond has its own OpenType and PostScript fonts, for example,
aybabtu.otf, and feta-alphabet11.pfb and so on.

fonts/ec-fonts-mftraced is heavy package, please remove dependency to
fonts/ec-fonts-mftraced from print/lilypond.

Also, fonts/mftrace is not needed by print/lilypond.

Index: Makefile
RCS file: /cvsroot/pkgsrc/print/lilypond/Makefile,v
retrieving revision 1.66
diff -u -r1.66 Makefile
--- Makefile    13 Jan 2011 13:39:13 -0000      1.66
+++ Makefile    7 Mar 2011 12:49:33 -0000
@@ -12,10 +12,6 @@
 PKG_DESTDIR_SUPPORT=   user-destdir
-DEPENDS+=      ec-fonts-mftraced-[0-9]*:../../fonts/ec-fonts-mftraced
-BUILDLINK_API_DEPENDS.mftrace+=        mftrace>=1.1.0
 USE_LANGUAGES=         c c++
@@ -45,7 +41,6 @@
 .include "../../devel/pango/"
 .include "../../fonts/fontconfig/"
-.include "../../fonts/mftrace/"
 .include "../../lang/guile/"
 .include "../../lang/python/"
 .include "../../mk/"


Home | Main Index | Thread Index | Old Index