pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/44689: IPv6 support disabled by default in chat/irssi

The following reply was made to PR pkg/44689; it has been noted by GNATS.

From: Thomas Klausner <>
To: NetBSD bugtracking <>
Subject: Re: pkg/44689: IPv6 support disabled by default in chat/irssi
Date: Sun, 6 Mar 2011 15:58:07 +0100

 On Sun, Mar 06, 2011 at 12:20:04PM +0000, Francois Tigeot wrote:
 >  My point is there should not be an 'inet6' option anymore.
 >  We're only month from IPv4 depletion in RIR pools and some organizations  
 > are
 >  deploying IPv6-only network right now.
 >  Heck, I figured out this issue trying to connect to an IPv6-only server.
 >  If some people want to disable IPv6, they could use a 'noinet6' option but
 >  in 2011, IPv6 support should be enabled by default.
 >  The only exceptions should be for brain-damaged software such as Java, where
 >  enabling IPv6 disables IPv4 support.
 I understand your point.
 We do not want "nofoo" options in pkgsrc though.
 My point is that we should turn the inet6 option on by default for all
 platforms, the same as you say.  Not just for one package at a time
 like here.

Home | Main Index | Thread Index | Old Index