pkgsrc-Bugs archive

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index][Old Index]

Re: pkg/43518 (converters/libiconv fails to build on OpenSolaris)

The following reply was made to PR pkg/43518; it has been noted by GNATS.

From: "David H. Gutteridge" <>
To: Tim Zingelman <>,
Subject: Re: pkg/43518 (converters/libiconv fails to build on OpenSolaris)
Date: Mon, 28 Jun 2010 21:06:27 -0400

 On 2010-06-28, at 12:30 PM, Tim Zingelman wrote:
 >On Mon, Jun 28, 2010 at 11:17 AM,  <> wrote:
 >>Synopsis: converters/libiconv fails to build on OpenSolaris
 >>State-Changed-From-To: open->feedback
 >>State-Changed-When: Mon, 28 Jun 2010 16:17:57 +0000
 >>feedback requested from submitter
 >Not sure if the message below got to you or not... or is delayed...
 >sorry if it is a duplicate... (I just added it to the PR.)
 >It appears that something has over-written your /usr/ccs/bin/ld.  I
 >just downloaded opensolaris 2008.05, and /usr/ccs/bin/ld -V reports:
 > ld: Software Generation Utilities - Solaris Link Editors: 5.11-1.622
 >not GNU ld.
 >Are you able to recover the original ld from a backup or the install
 >disk and see if that resolves your problem?
 Sorry, that was a bone-headed mistake on my part.  /usr/ccs/bin/ld is
 in fact the stock one that comes with that release of OpenSolaris, it
 reports as yours does above.  I assumed that was what I would be
 getting with "ld -V", but in fact, /usr/gnu/bin was in my path first,
 so that's what was reporting before, GNU binutils must've been
 packaged with GCC.
 I just retried the build and checked to make sure it was calling
 /usr/ccs/bin/ld, and it is.  (configure output snippet below)
 checking for ld used by gcc... /usr/ccs/bin/ld
 checking if the linker (/usr/ccs/bin/ld) is GNU ld... no

Home | Main Index | Thread Index | Old Index